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The order numbers for MMC cards are in the following table:
Micro Memory Card / S7-300
]64 Kbytes 6ES7 953-8LF11-0AAQ
\128 Kbytes 6ES7 953-8LG11-0AAO

|
1
512 Kbytes | 6EST 953-8LJ11-0AAQ
|
|
|

Order number

‘2 Mbytes 6ES7 953-8LL11-0AAO
’4 Mbytes 6ES7 953-8LM11-0AAQ
’8 Mbytes 6ES7 953-8LP11-0AAO
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QUESTION 2 : MMC +_EAFfEFE PR BRE SR R I PRI R AT 4 2

Is there any restriction to the number of blocks I can load onto an MMC (Micro
Memory Card) ?

ANSWER:
Yes, there is a limited number of blocks you can load onto an MMC depending its
size as shown by the table below:

|Type |MLFB |Maximum number of blocks
MC 64KB |6ES7953-8LF11-0AA0 | 768
MMC 128KB |6ES7953-8LG11-0AA0 | 1024
MMC 512KB |6ES7953-8LJ 11-0AA0 | 2560
MMC 2B |6ES7953-8LL11-0AA0 | 6528
MC 4B |6ES7953-8LM11-0AA0 | 12672

Table 1: Maximum number of blocks on an MMC
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Please note here the applicable quantity framework for each CPU (number of blocks
altogether).

R e

QUESTION 3 : 4l k& MMC = LR SRR /7 ?

How can I delete the data or program on a MMC (Micro Memory Card)?

You can use the following procedure to delete the block on an MMC in the CPU:

—_

The MMC to be deleted is slotted in the CPU.

2. In the SIMATIC Manager, switch to online mode via “View > Online” or by
pressing the appropriate button.

3. In the Online window, you select the block folder.

4. Select all the blocks in the folder which you want to delete

Click the “Delete” key on your PC keyboard (you can acknowledge the

message that system functions cannot be deleted).

ol

& (8l

QUESTION 4 : 31X I PLC #A MMC £/5, STOP AT AMENKR, B4AJr? 8 afasg=ik MMC?
Why does the STOP LED flash on my CPU 31xC when the MMC (Micro Memory Card) is
slotted? The CPU does not behave like this with other MMCs

ANSWER:

The MMC in your CPU is not formatted or contains data that cannot be interpreted by
this CPU (e.g. the configuration of a different CPU type or an operating system not
compatible with the CPU).

WARNING:
When you format the MMC all the data that is located on the MMC is deleted!

Proceed as follows to format the MMC.

1. Your CPU requests an overall reset (slow flashing of the STOP LED).

2. Put the switch into the MRES position and hold it there until the STOP LED
lights permanently (approx. 9 seconds)

3. You must then release the switch within the next 3 seconds and then put it
back into the MRES position. The STOP-LED now flashes during formatting

If the MMC cannot be formatted as described above, then the MMC is defective
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NOTE:

It is only possible to format the MMC if there is data located on the MMC that is
invalid for the CPU. Otherwise the MMC is only initialized through the steps
described.

More information on the MMC is available in Entry ID: 8861901

R [

QUESTION 5 :3A MMC ) S7300 PLC ANBEIF & FH SFCH4 FEfFH?
Why does the SFC 54 “RD_DPARM” not work with the new S7-300 CPU with MMC?

ANSWER:

In the new S7-300 CPUs with micro Memory Card, SFC 54 ”"RD DPRARM” for reading out
a data record of a chosen block of the system data configured with STEP 7 has been
replaced by SFC 102 “RD_DPARA”.

SFC 102 ”“RD DPARA”, in contrast to the old SFC 54 “RD DPARM” is an asynchronously
executed system function. This means that the processing is extended over various
SFC calls.

Blocks containing SFC 54 ”“RD DPARM” can not be loaded to a new S7-300 CPU with MMC.
Therefore, please replace the call fo the SFC 54 “RD DPARM” by the call of the SFC
102 “RD_DPARA” and adjust your programming logic to the asynchronous behaviour of
the SFC 102 “RD_DPARA” an.

Below, you will find a comparison of the two system functions:

SFC 54 “RD_DPARM” |SFC 102 “RD_DPARA” |Observations

’ Inputs

Function will be executed only with

— REQ REQ=1; new for SFC 102

Parameter has been dropped for SFC 102;
see LADDR

SFC 54: any block address, specification
of the E resp. A address range over I0ID
((B#16#54=Peripherie Eingang; B#16#55=
peripherial output) SFC 102: any block
address; Specification of the E resp. A
address range over bit 15 of LADDR (most
siginficant bit) Bitl5=0 —> peripherial
input Bit15=1 -> peripherial output

RECNUM RECNUM luse identically
‘ Output ‘

LADDR LADDR

use identically; however, there are
RET VAL RET VAL additional error numbers for SFC 102 at
disposition.
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BUSY=1; the order has not been finished

- BUSY so far, there are no results at
disposition
RECORD RECORD use identically

Table 1: Comparison SFC 54 and SFC 102

& [l

QUESTION 6 : SRFH MMC K S7300 F1 C7613, 635 %1 CPU &4 52 BRE IR (R REThBE A 2
How does the remanence function of the S7-300 CPUs and C7-613 and C7-635 compact
devices work with Micro Memory Card?

ANSWER:

The remanence characteristics described below affect the S7-300 compact CPUs, S7-
300 modular CPUs and the C7-613 and C7-635 compact devices with MMC. We describe
the remanence characteristics after changes in operating mode in terms of data
blocks, times, counters and markers

Data blocks:
e CPU STOP/RUN or Power OFF/ON

1. Database contents of CPUs 31xC, 312, 314, 315-2DP, C7-613 and
C7-635 are always remanent

2. The DBs can be defined as remanent or non-remanent for the
CPU 317-2DP.
Therefore, a setting in STEP 7 (V5.2 +SP1) is required for
CPU317—2DP:
0 An explanation for the activation or deactivation of
the option “Non-Retain” in the block properties of the
DB, can be found in the entry-ID: 17146856 or
0 a DB was created with SFC 82 “CREA-DBL”. While
creating a DB with SFC 82 it is determined in the
attributes of the DB in Bit 2, whether the DB shall
get remanent or not

Note:
Only 256K bytes of the main memory (512 Kbyte) can be used
for remanent data blocks at a CPU 317-2DP! No remanent DB
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will be created anymore and the value 80B2 (not sufficient
main memory) will be displayed, if the main memory is too
small for remanent data blocks

e Memory reset (MRES)

1. The data will be reset to the values in the loading memory
(initial value). These are the last current values which were
loaded with the PG into the CPU or which were written with
the SFC84 into the loading memory.

2. All blocks of the loading memory remain unchanged. The data
blocks are initialized in the main memory.

e CPU Power OFF —> pull MMC -> Power ON -> Power OFF —-> plug MMC —> Power ON

1. The data are reset to the values in the loading memory. These
are the last current values which were loaded from the PG
into the CPU or written into the loading memory with SFC84.

2. All blocks of the loading memory remain unchanged. The data
blocks are initialized in the main memory.

Note:

If it is required to safeguard current data, those have to be saved
on the MMC (loading memory). SFC84 can be used for this purpose. The
frequency of the write accesses on the loading memory is critical
because a MMC only allows 100, 000 write accesses

Markers, times and counter:
These operand areas can be defined as remanent or non—remanent in the HW
configuration under “Object properties CPU > remanence”

e CPU STOP/RUN or Power OFF/ON
These operand areas keep their values if they were defined remanent.
Otherwise they lose the values and will be initialized with 70"

e Memory reset (MRES)
These operand areas are deleted during the memory reset, regardless whether
they were defined remanent or non—remanent

e CPU Power OFF —> Remove MMC —> Power ON —> Power OFF —> Insert MMC -> Power
ON
If they were defined as remanent, these operand areas retain their values
Otherwise they lose their values and initialize with “0”. This
characteristic applies if the same unchanged MMC is inserted again.

QUESTION:
What does “Non—Retain” mean in the Properties — Data Block dialog?

ANSWER:

In STEP 7 version V5.2 + SP1 and higher you have the option of selecting the
property “Non-Retain” in “Properties — Data Block” in the “General — Part 2” tab.
You can define the remanence behavior of data blocks with this option.
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Properties - Data Block

General - Part 1 General - Part 2 Il:allx I Attributes

Mame [Header): I
Earnily; I

Wersion [Header): IU.'l
Author; I

—Lengths
Local Drata:
[rata: 0 bytes
Load Memor Requirement; 80 butes

“Work Memomy Requirement; 3E bytes

[~ DE iz virite-pratected in the PLC

[ Enow-how pratection

V|

[~ Standard black
[ Unlinked

Cancel Help

Fig. 1: Properties — Data Block

The requirement for this option is that the CPU supports the Retain property of
data blocks.

www.200smart.com

A data block with the property “Non—Retain” is not stored in the remanence memory

in a CPU 317 -2DP and is thus reset to the original load values at each power

OFF/ON or each STOP-RUN transition of the CPU.

A data block with the “Non-Retain” property occupies RAM space as usual, but no
Temanence memory space

Note:

The CPU 317-2DP has a RAM of 512 KB, but only 256 KB of data can be retained

& (8l

QUESTION 7 : FUHs—LRGECAFEE TR H A5 ST A7t B MMC £

Can I also save other files that belong to the project or system on the MC/MMC?

ANSWER:

You can save any file connected with the system on the MC/MMC.
Procedure:

e Slot the memory card or micro memory card into the PG.
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e Open the SIMATIC-Manager.
e Go to "File > S7-Memory Card > Open”
e Then go to "PLC > Save to Memory Card ...”~.

ISIMATIE Manager - 57 memory card

PLC Wiew Options Window  Help

File Edit Insert
D|=| 81|

EST MEMory d

~-{gH 57 memon

Access Rights

B HEPLCEE Tl

< MNoFi

Download
Compile And Download Objects
plzad

lUpload Statian

Copy RO Eo ROn, .,
Download user pragran e memary: card

CEr{ L

Save ko Memo ard

Retrieve From Memary Card.,

Mamage MF Systenm, ..

Display Accessible Modes

R Messages. ..
Display. Force Walues
IMonitarMaodity Wariables

Diagnostic/Setting

FROFIELS

Assign Ethernet Address. .,
Assign Fia/PE

Cancel PEEC assignment
Update Operating Syskem. ..

Fig. 1: SIMATIC Manager ;187 memory card

e In the left file explorer you select the required file and mark it for

saving with the “—>” button.

www.200smart.com
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QSIMATIE Manager - 57 memory card

File Edit Imsert PLC Wiew ©Options ‘Window Help

D|c| 82| #[5(w dal [= =5 2 E

EST memory card

Save files ko Memory Card

~STEP ¥ Data

Projects/Libranes... |

= Oither file:

Search in: IE:' MTEF ﬂ

D:AMTBF wpdate_11 1z

update_11

I (u] | Cancel | Help | I

e If you want to remove files again from the selection, use the "<—” button.
. Click “0K” to save the selected data to the memory card or micro
memory card.

e You receive an acknowledgment once the data has been saved.

e Then the data transferred is displayed in the ”S7 Memory Card” window.

QSIMHTIE Manager - 57 memory card

File Edit Insert PLZ  Wiew Options ‘Window Help
Ol 28)am| 0 e dal [= 2] Sof g2

..... .Iﬁ ST TTIERC card update_'l 1.uls

Fig. 3: View of data in memory card window

Note:

You can only use this function for an S7-300 Micro Memory Card and S7-400 Flash
EPROM card.

B [5
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QUESTION 8 :
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FABHKS B STEPT I H S BEHRAFTE MMC R |, 3EHEZ I MMC?

How can I determine the size of the MMC so that I can store my complete STEP 7
project on it?

ANSWER:

In order to choose the appropriate MMC for your project you need to know the
overall size of the project and the size of the blocks to be loaded. You can
determine the size of the project as described below:

First archive your STEP 7 project. Then open the archived project in Windows
Explorer and determine its size (select and right-click). This gives you the size
of the archived file.

test.zip Properties | 2=l

General | Seculityl Summary

Itest.zip
Type of il Wingip-Datei
Opens with: @ WinZip Executable Change... |
Location: H:4Fad-Daten
Size: 393 KB (403,340 bytes)
Size on disk: 396 KB [405.504 bytes] |
Created: Freitag, 13. Dezember 2002, 13:18:01
todified: Freitag, 13. Dezember 2002, 13:15:06
Arccezzed: Freitag, 13. Dezember 2002, 131831
Bttt bes: [~ Hidden v dmchive

Ok I Cancel | Apply

Fig. 1: File properties

Load your blocks into the CPU. Now you still have to select “PLC > Module
Information > Memory”. There, in “Load memory RAM + EPROM”, you can see the size of
the assigned load memory.
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ﬁlMudule Information - CPU 315-2 DP ONLINE o ] |
Path: |.-’-'«c:n:essible Modes'MPl = 2 [directy) Operating mode of the CPL: @ RN
Statuz: OF Mat a force job
Time System I Perfarmance D ata | [ ication I Stacks
General I Diagrostic Buffer : Scan Cycle Time
Aasighment;
[sizes in bytes] 4% 9%
Load memory BAM + EPRO W ork, Memu:ury|
Free: E 1 118.800
B Assioned: 12272
Tatal: 131.072
Largest Free Block: SEs
b ax. Fluggable: -
Compress | Details bMemorn Area... |

Cloze I Update | FErrintt... Help |

Fig. 2: Load memory

You must add this value to the size of the archived project you have already
determined. This gives you the overall amount of memory required to store your
complete project on an MMC.
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QUESTION 9 : XA MMC ¥ ST300PLC #E4T T Ii%, HESIE T HW, W4 REXT MMC f#
%,  iER MMC & LRSS ?

2 W RAD T #7E ST-300CPU Protection J& M BT e 50y, 4% L HEE R ]
siemens [KZFEas PG (6ES7T798-0BA00-0XA0) | [¥yis-FFlinl % 1] USB 2 LI fKiz K #% (USB
prommer 6ES7792—-0AA00-0XA0) , #E#¢ SIMATIC Manager T FHISEH  File>S7 Memory
Card=>delete JEIMH[R MMC K LA A Z, IXFE MMC 3t v AER — N AR INE s KA T,
(BT MMC R HEA TR 25, B MMC P AR 5 B
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